Support Center

How do I install Service Pack 1 for Windows 7?

Last Updated: Apr 11, 2016 02:04PM EDT
Some of the products available through the Epic Games launcher require that players using Windows 7 have Service Pack 1 installed.  You can find more information about Service Pack 1 and instructions for how to install it at this page on the Microsoft support site.

If you are prompted by the launcher to install Service Pack 1 and already have it installed or are on a newer version of Windows, check the launcher's application compatibility mode settings.  These settings make programs think that they are running an older version of Windows, and should always be disabled for the Epic Games launcher.

To check the Windows compatibility mode options, please do the following:
  • Right click the Epic Games Launcher desktop shortcut.
  • Select Properties.
  • Select the Compatibility tab.
  • Make sure that the Run this program in compatibility mode option is unchecked.
    • If you absolutely require compatibility mode, make sure that the selected version of Windows is Windows 7 SP1 or newer.

Contact Us

0b4c5e725dabfd13129a608f44c26b1f@epicgames.desk-mail.com
http://assets0.desk.com/
false
desk
Liquid error: undefined method `gsub' for nil:NilClass
seconds ago
Liquid error: undefined method `gsub' for nil:NilClass
Liquid error: undefined method `gsub' for nil:NilClass
Liquid error: undefined method `gsub' for nil:NilClass
Liquid error: undefined method `gsub' for nil:NilClass
Liquid error: undefined method `gsub' for nil:NilClass
Liquid error: undefined method `gsub' for nil:NilClass
about
false
Liquid error: undefined method `gsub' for nil:NilClass
/customer/en/portal/articles/autocomplete